May 12, 2011

BPOS Offline .... again

*** UPDATE 12:12PM CST ***

From Microsoft Health Dashboard:


The BPOS Operations team is working to resolve service degradation for Exchange Online mail flow for organizations served from this region. Users in affected organizations will experiencing ~40 minute delays when trying to send or receive e-mail using Outlook, OWA, or mobile devices. The BPOS Operations team is actively working to restore service. Next update will be within one hour or when new information is available.


Not sure about anyone else, but ~40 minutes is off by about infinity for me.

----------------------------------------------

Two days in a row now, and if you were watching Twitter it would appear to be affecting a lot of people in the NOAM region. Oddly, the Health dashboard still doesn't show a problem:


Try calling MS support though, it will just hang up on you.

May 10, 2011

Microsoft Exchange Online Outage

**2:20PM CST UPDATE**: Microsoft posted another update to the NOAM Health board:

The BPOS Operations team continues to investigate service degradation issues with Exchange Online mail flow for organizations served from this region. The next service update will be provided within 2 hours if the issue is not resolved.

Hopefully we here something else soon.

------------------------------------------------------------------

Microsoft Exchange Online (and BPOS by extension) are currently having issues with mail flow (read: there isn't any).

From Microsoft as of 11:40am:

The BPOS Operations team is investigating alerts indicating service degradation for Exchange Online mail flow for organizations served from this region. Users in affected organizations may be experiencing delays when trying to send or receive e-mail using Outlook, OWA, or mobile devices. The BPOS Operations team is actively working to determine the root cause and restore service.

When I called in initially, I could hear the service manager yelling in the background as the call queue exploded from a few users to over 60 in a matter of seconds.

Who else is seeing this issue? What have been your impressions of BPOS recently? Anyone on Office 360 having the same problem?